Best to stick with V4.3?

Prepar3D - Lockheed Martin has taken the FSX platform into a new level aimed at the professional.

Best to stick with V4.3?

Postby striker » Sun Apr 07, 2019 12:29 pm

I hear v4.4 will not accept a lot of FSX native aircraft due to 64bit.

I also guess that if P3D v4.5/ v5 / or whatever, goes to native p3d models only (so no FSX planes will work) is it really best to stick with v4.3 but no higher?
Because if it's native p3d aircraft only then years of files are wiped out? I hope not.
Or maybe 4.4 onwards will also accept FSX native as long as they are 64bit
User avatar
striker
2nd Lieutenant
2nd Lieutenant
 
Posts: 209
Joined: Fri Feb 01, 2002 3:18 pm
Location: Wilmington, NC

Re: Best to stick with V4.3?

Postby SpaceHippy1975 » Sun Apr 07, 2019 12:46 pm

Hi,

P3D has been 64bit since v4.0, previous versions up to v3.* were 34bit compatible.

You should still able to buy or stick with earlier versions of P3D if you wished to use older aircraft, although others should be able to clear this up if I'm wrong!

Hope this helps.

Keith.
Flying: P3D V4.4 ~ Also Trying: X-Plane 11.10
My Rig:
Intel Core i7 - 6700K CPU @ 4.5GHz,
ASUS ROG Maximus VIII Hero Z170 Motherboard,
EVGA GeForce GTX 1080 Ti SC2 GAMING 11GB GPU,
G.Skill Ripjaw 16GB DDR4 3200MHz RAM,
Asus MX299Q 29" 2560x1080 IPS Ultra Widescreen Monitor,
Bose Companion 2 Series III Speakers,
Saitek X-55 Rhino H.O.T.A.S
User avatar
SpaceHippy1975
2nd Lieutenant
2nd Lieutenant
 
Posts: 186
Joined: Mon Sep 23, 2013 3:37 pm
Location: Deep & Darkest Berkshire - England.

Re: Best to stick with V4.3?

Postby Daube » Mon Apr 08, 2019 5:18 pm

As Keith stated above, all FSX planes with .GAU or .DLL gauges/systems will not work in P3Dv4, no matter the sub-version (from 4.0 to 4.4).
.GAU or .DLL gauges made for FSX are all 32 bits, then incompatible with P3Dv4 which is 64 bits.
There is no difference between P3Dv4.3 and 4.4 on that point.
Note that FSX planes with .XML gauges will still work, though.
User avatar
Daube
Lieutenant Colonel
Lieutenant Colonel
 
Posts: 6340
Joined: Wed Oct 05, 2005 8:34 am
Location: Nice (FR)

Re: Best to stick with V4.3?

Postby Canuck1955 » Tue Apr 09, 2019 12:54 pm

and now they just released v4.5
Canuck1955
2nd Lieutenant
2nd Lieutenant
 
Posts: 214
Joined: Wed Jul 20, 2016 3:24 pm
Location: CYXX

Re: Best to stick with V4.3?

Postby papituwall » Thu Apr 11, 2019 1:11 am

Go direct to 4.5
User avatar
papituwall
Captain
Captain
 
Posts: 679
Joined: Thu Sep 19, 2013 1:42 pm
Location: LEZG

Re: Best to stick with V4.3?

Postby Daube » Thu Apr 18, 2019 9:18 am

For info, I would advise you NOT to jump on 4.5 yet.
Some performance problems have been acknowledged by Lockheed and some fix is on the way (hopefully).
It seems some kind of autogen objects (maybe the buildings with complex shapes -not just a rectangle- called "polyline") have a deep FPS impact, resulting in 50% less FPS in 4.5 than in 4.4.
So if you are still running 4.4, just keep it like that for a while :)
User avatar
Daube
Lieutenant Colonel
Lieutenant Colonel
 
Posts: 6340
Joined: Wed Oct 05, 2005 8:34 am
Location: Nice (FR)

Re: Best to stick with V4.3?

Postby Canuck1955 » Sun Apr 21, 2019 11:39 am

I have just spent the last 3 days in v5. And I say this as a reluctant FSXer unwilling to move on. P3D4v5 is wonderful, it is stable and looks great with FTX Global and LC. I know there is a patch due, but for me I am getting fps in the high 60's - cannot manage that in FSX.
Go for it.
Canuck1955
2nd Lieutenant
2nd Lieutenant
 
Posts: 214
Joined: Wed Jul 20, 2016 3:24 pm
Location: CYXX

Re: Best to stick with V4.3?

Postby Tleilaxian » Tue May 14, 2019 8:25 am

I just installed 4.5 yesterday and although I have not done a lot of testing, I did test "FSX/P3D Boeing 777-200LR El Al Package" and it ran flawlessly (@cevans A/T arm worked both in VC and 2d cockpit, if you remember the issue I posted about in in the FSX forum). I don't know if that model meets the criteria that you are concerned with; maybe the incomparable and incredible asset to the sim world (and specifically Simviation) @cevans could answer that for you. But regardless of the file types used, it runs on the P3D 4.5 version released yesterday (**Edit** Ok, it wasn't released yesterday but it's the distribution package as of yesterday) ...for whatever that's worth. :)
Tleilaxian
Ground hog
Ground hog
 
Posts: 19
Joined: Wed May 08, 2019 12:00 pm

Re: Best to stick with V4.3?

Postby Daube » Tue May 14, 2019 5:10 pm

I have read some feedback about the newest 4.5 'hotfix" on the Prepar3D forums at LM.
While most users agree the FPS problem has been mostly fixed, a few of them are reporting numerous application crashes to desktop (CTD).
I think I'll stay in 4.4 for a while.
User avatar
Daube
Lieutenant Colonel
Lieutenant Colonel
 
Posts: 6340
Joined: Wed Oct 05, 2005 8:34 am
Location: Nice (FR)

Re: Best to stick with V4.3?

Postby SpaceHippy1975 » Fri May 17, 2019 11:19 am

Hi All,

I was having the FPS issue that was reported by others (they were pretty much halved) so rolled back to v4.4

Saw that they've released an updated v4.5 client, I've not had any issues with CTD despite flying for a couple of hours under a few different scenarios & framerates are back to normal too!

Keith.
Flying: P3D V4.4 ~ Also Trying: X-Plane 11.10
My Rig:
Intel Core i7 - 6700K CPU @ 4.5GHz,
ASUS ROG Maximus VIII Hero Z170 Motherboard,
EVGA GeForce GTX 1080 Ti SC2 GAMING 11GB GPU,
G.Skill Ripjaw 16GB DDR4 3200MHz RAM,
Asus MX299Q 29" 2560x1080 IPS Ultra Widescreen Monitor,
Bose Companion 2 Series III Speakers,
Saitek X-55 Rhino H.O.T.A.S
User avatar
SpaceHippy1975
2nd Lieutenant
2nd Lieutenant
 
Posts: 186
Joined: Mon Sep 23, 2013 3:37 pm
Location: Deep & Darkest Berkshire - England.


Return to Prepar3D

Who is online

Users browsing this forum: No registered users and 261 guests