Simviation Forum
http://forums.simviation.com/cgi-bin/yabb25/YaBB.pl
Current Flight Simulator Series >> FS 2004 - A Century of Flight >> PROBLEM: don't hear engine, ATC
http://forums.simviation.com/cgi-bin/yabb25/YaBB.pl?num=1124141401

Message started by hypersonic on Aug 15th, 2005 at 5:30pm

Title: PROBLEM: don't hear engine, ATC
Post by hypersonic on Aug 15th, 2005 at 5:30pm
Hi!

Since  installed a Tupolev TU-144, the engine and ATC sounds don't work. When I load some planes (original and addons) into the simulation, I only hear the rumble noise of taxiing. So I removed the Tupolev and tried it again. Nothing happened.

Basically you can play the sound files in Windows Media Player. But in some .WAVs a error message is displayed. "Class Factory can't be found!".
So I assume that Flight Simulator also cannot play these files. Maybe they're damaged.
So, the question is: What is "ClassFactory" related to wav files and how can I fix this problem?  ???

Title: Re: PROBLEM: don't hear engine, ATC
Post by || Andy || on Aug 15th, 2005 at 6:15pm
Have you checked the sound settings in FS arnt turned down..?

Title: Re: PROBLEM: don't hear engine, ATC
Post by chief1995 on Aug 16th, 2005 at 1:12pm
Hi Hypersonic,
I have had the same problem for months, I lost my ATC sounds and the engine sound on some planes for instance none of my Boeings have sound, my King Air either and some others , but my Cessnas do, also some add on do ie; DHC Beaver 2,  C-130, etc. I have tried just about everything short of a complete reinstall of my XP system.
I have all other sounds on my computer working.
I am sorry I can't help you, but maybe others can  give us some ideas.

Chief

Title: Re: PROBLEM: don't hear engine, ATC
Post by JerryH on Aug 16th, 2005 at 6:17pm
hypersonic & chief,

You're both describing a problem caused by corrupted audio CODECs. The solution is to uninstall and reinstall the CODECs from your original Windows CD. These files are not a part of FS.

If you're not sure of how to do this, go to the Microsoft website and search the Knowledge Base (KB)for "KB177252". The title of this article is "Flight Simulator: No Instructor, Pilot or ATC Voices ..... ". This problem will also affect jet engine sounds.

The KB article above refers to Win98, WinME and Win2000. If you have WinXP, the instructions may still be useful. If not, you'll need to find a CODECs guru to help you.

I know little about the CODECs, but had your identical problem about three years ago.  Reinstalling the CODECs did the trick.

Let us know if this solved the problem.

Regards,
JerryH

Title: Re: PROBLEM: don't hear engine, ATC
Post by Kevin on Aug 16th, 2005 at 8:09pm
Jerry is correct.  I had the same problem, with the same solution...  I was beating my head on the table for weeks.  ::)

Title: Re: PROBLEM: don't hear engine, ATC
Post by hypersonic on Aug 17th, 2005 at 9:40am
Thanks fpr replies !  :)

It works !

Problem was, that Microsoft ADPCM codec was missing (I found it out with Gspot, a tool to determine required codecs for audio/vidio files), so I downloaded the ACE codec pack 6 Professional. Noiw I hear the wonderful sounds of engines and ATC again!  8)

Title: Re: PROBLEM: don't hear engine, ATC
Post by Kevin on Aug 17th, 2005 at 10:21am
I'm going to add this to the FAQ at the beginning of the forum.  It's info worth saving...

Title: Re: PROBLEM: don't hear engine, ATC
Post by ctjoyce on Aug 17th, 2005 at 11:27am
The other problem could be that these aircraft didnt come with sound. It could be that all that is in the sounds folder is the sound.cfg However glad to see the problem is fixed


Cheers
Cameron

Title: Re: PROBLEM: don't hear engine, ATC
Post by turbofire on Sep 30th, 2011 at 9:41am
Generally my sounds all work, except, extra sounds such as announcements.  I get the message that these sound cannot be used and I am forced to take them off.  Anyone know what is going on?

Simviation Forum » Powered by YaBB 2.5 AE!
YaBB Forum Software © 2000-2010. All Rights Reserved.